HA hängt sich immer wieder auf

Keine passende Kategorie? Bzw. Allgemeine Diskussionen rund um Home Assistant.
Antworten
Benutzeravatar
Friedi
Beiträge: 201
Registriert: Do 22. Jul 2021, 16:57

HA hängt sich immer wieder auf

Beitrag von Friedi »

Ich habe seit kurzem das Problem, dass sich HA aufhängt bzw. stehen bleibt.

Da geht wirklich gar nichts mehr. Nicht mal mehr der geordnete reboot.

Ich betreibe HA auf einer SSD mit einem Raspi 4. Imho treten die Probleme erst seit dem November-Release auf. Kann aber ja auch Zufall sein.
Hat irgendjemand von euch ähnliche Probleme bzw. habt ihr davon irgendwo gelesen?
Benutzeravatar
Osorkon
Administrator
Beiträge: 238
Registriert: Sa 17. Jul 2021, 16:53
Wohnort: Langenargen
Kontaktdaten:

Re: HA hängt sich immer wieder auf

Beitrag von Osorkon »

Habe hier selber HA OS auf nem Pi 4 mit SSD am laufen.
Jetzt schon seit 2 Jahren und keinerlei Probleme?!

Wenn Du den Stecker ziehen tust, dann lauft HA wieder?
Kann es ein Hitze Problem sein? Hast Du Lüfter oder zumindest passive Kühlkörper am Start?
Wie sieht Dein Hardware setup insgesamt aus?

Gruß
Osorkon
Einer muss ja für Ordnung sorgen. :D
Benutzeravatar
Friedi
Beiträge: 201
Registriert: Do 22. Jul 2021, 16:57

Re: HA hängt sich immer wieder auf

Beitrag von Friedi »

Osorkon hat geschrieben: Sa 27. Nov 2021, 16:40 Wenn Du den Stecker ziehen tust, dann lauft HA wieder?
Ja
Osorkon hat geschrieben: Sa 27. Nov 2021, 16:40 Kann es ein Hitze Problem sein? Hast Du Lüfter oder zumindest passive Kühlkörper am Start?
Na klar :)
Osorkon hat geschrieben: Sa 27. Nov 2021, 16:40 Wie sieht Dein Hardware setup insgesamt aus?
Ich hab dasselbe Zeug wie du. Ich benutzte deine Liste :)
Benutzeravatar
Osorkon
Administrator
Beiträge: 238
Registriert: Sa 17. Jul 2021, 16:53
Wohnort: Langenargen
Kontaktdaten:

Re: HA hängt sich immer wieder auf

Beitrag von Osorkon »

Friedi hat geschrieben: Sa 27. Nov 2021, 16:48 Ich hab dasselbe Zeug wie du. Ich benutzte deine Liste
Ahhh! Du warst es! 😀

Kannst Du es eingrenzen. Ist es HA oder HA OS, also Core oder Host, der sich aufhängt?

Gruß
Osorkon
Einer muss ja für Ordnung sorgen. :D
Benutzeravatar
Friedi
Beiträge: 201
Registriert: Do 22. Jul 2021, 16:57

Re: HA hängt sich immer wieder auf

Beitrag von Friedi »

Osorkon hat geschrieben: Sa 27. Nov 2021, 17:23
Kannst Du es eingrenzen. Ist es HA oder HA OS, also Core oder Host, der sich aufhängt?
Leider nein. Es geht halt nix mehr. Es hilft nur noch Stecker ziehen.
Ich hab das mal in ein paar FB-Gruppen reingesetzt und ich bin wohl nicht der Einzige.
Leider kommen da von dem einen Betreiber nur dumme Sprüche wie „Nutzt du einen vernünftigen Rechner oder nen billigen Bastelrechner?“
Benutzeravatar
Osorkon
Administrator
Beiträge: 238
Registriert: Sa 17. Jul 2021, 16:53
Wohnort: Langenargen
Kontaktdaten:

Re: HA hängt sich immer wieder auf

Beitrag von Osorkon »

Wenn das System hängt, kannst Du den Pi noch anpingen?
Kommst Du per ssh noch drauf?

Gruß
Osorkon
Einer muss ja für Ordnung sorgen. :D
Benutzeravatar
Friedi
Beiträge: 201
Registriert: Do 22. Jul 2021, 16:57

Re: HA hängt sich immer wieder auf

Beitrag von Friedi »

Keine Ahnung.
Werde ich mal probieren, wobei ich mich mit SSH ehrlich gesagt nicht gut auskenne 🤷‍♂️
Benutzeravatar
carsten_h
Beiträge: 117
Registriert: Mo 2. Aug 2021, 11:07
Wohnort: Wunstorf

Re: HA hängt sich immer wieder auf

Beitrag von carsten_h »

Moin!

In der Facebook Gruppe hatte ich diesen Tipp schon gepostet und bei einem war er auch erfolgreich.
Das Problem ist, daß die neueren Releases von Home Assistant OS sich irgendwie nicht mit UAS von einigen USB-SATA Bridges vertragen. Dabei ist unter anderem auch die, die im Argon One Gehäuse ist.
Von Home Assistant Seite wird natürlich geschrieben, daß die Bridges sich nicht richtig verhalten. Da die aber die ganzen Monate vorher problemlos gelaufen sind, kann ich mir das nicht so richtig vorstellen.

Daher muß man das UAS für speziell die eigene Bridge ausschalten. Danach läuft es einwandfrei durch. Bei mir war es kein stehenbleiben, sondern ich mußte immer ca. 20 Sekunden warten bevor eine Logdatei angezeigt wurde. Manchmal gab es aber auch nur einen Fehler.
Hier ist der Link zu dem, was man Schritt für Schritt tun muß:
https://community.home-assistant.io/t/s ... /344375/22
Benutzeravatar
carsten_h
Beiträge: 117
Registriert: Mo 2. Aug 2021, 11:07
Wohnort: Wunstorf

Re: HA hängt sich immer wieder auf

Beitrag von carsten_h »

Friedi hat geschrieben: Sa 27. Nov 2021, 18:22„Nutzt du einen vernünftigen Rechner oder nen billigen Bastelrechner?“
Ich glaube, ich weiß, wen Du meinst. :-(
Die Antworten nehme ich schon gar nicht mehr wahr. Es ist genauso wie dir Reaktionen auf einen ConBee II.
Benutzeravatar
Friedi
Beiträge: 201
Registriert: Do 22. Jul 2021, 16:57

Re: HA hängt sich immer wieder auf

Beitrag von Friedi »

carsten_h hat geschrieben: Mo 29. Nov 2021, 09:03 Reaktionen auf einen ConBee II.
Wieso, was kommt denn da so?
Und was wird denn alternativ vorgeschlagen?
Benutzeravatar
carsten_h
Beiträge: 117
Registriert: Mo 2. Aug 2021, 11:07
Wohnort: Wunstorf

Re: HA hängt sich immer wieder auf

Beitrag von carsten_h »

Friedi hat geschrieben: Mo 29. Nov 2021, 10:18 Wieso, was kommt denn da so?
Das der Stick das Letzte (jetzt nicht hundertprozentig wiedergegeben) ist und nur die CC26* Sticks vernünftig funktionieren. Und deCONZ ist sowieso ganz schlimm.
Was mich dabei aufregt ist, das nicht versucht wir die Probleme zu lösen, sondern einzig etwas anderes genommen werden soll. Dabei lässt sich das Problem meist sicher einfach lösen. Nein, man muss halt missionarisch tätig werden.

Aber das gehört hier jetzt nicht hin.

Hast Du UAS einmal deaktiviert?
Benutzeravatar
Friedi
Beiträge: 201
Registriert: Do 22. Jul 2021, 16:57

Re: HA hängt sich immer wieder auf

Beitrag von Friedi »

carsten_h hat geschrieben: Mo 29. Nov 2021, 10:26 Das der Stick das Letzte (jetzt nicht hundertprozentig wiedergegeben) ist und nur die CC26* Sticks vernünftig funktionieren. Und deCONZ ist sowieso ganz schlimm.
Was mich dabei aufregt ist, das nicht versucht wir die Probleme zu lösen, sondern einzig etwas anderes genommen werden soll. Dabei lässt sich das Problem meist sicher einfach lösen. Nein, man muss halt missionarisch tätig werden.
Ja, der Typ ist schlimm :-/
carsten_h hat geschrieben: Mo 29. Nov 2021, 10:26
Hast Du UAS einmal deaktiviert?
Nein, ich habe jetzt mal die Fritz!Tools deaktiviert, da mir hier immer wieder mal Fehler aufgefallen sind. Schein bar läuft es jetzt stabil.
Aber ich muss erst mal weiter beobachten.
Benutzeravatar
carsten_h
Beiträge: 117
Registriert: Mo 2. Aug 2021, 11:07
Wohnort: Wunstorf

Re: HA hängt sich immer wieder auf

Beitrag von carsten_h »

Friedi hat geschrieben: Mo 29. Nov 2021, 13:53da mir hier immer wieder mal Fehler aufgefallen sind. Schein bar läuft es jetzt stabil.
Hast Du folgendes in der configuration.yaml eingetragen:

Code: Alles auswählen

logger:
  default: info
  logs:
    fritzconnection: info
Das ist seit der Home Assistant Core 2021.11.x notwendig, da ansonsten das Log durch irgendwelche Firtz!Box Meldungen überläuft. Damit könnte Dein Problem auch zu tun haben.
Dieses Problem ist anscheinend ab der 2021.12.x behoben, wenn ich das richtig verstanden habe.
Benutzeravatar
Friedi
Beiträge: 201
Registriert: Do 22. Jul 2021, 16:57

Re: HA hängt sich immer wieder auf

Beitrag von Friedi »

carsten_h hat geschrieben: Mo 29. Nov 2021, 14:04
Friedi hat geschrieben: Mo 29. Nov 2021, 13:53da mir hier immer wieder mal Fehler aufgefallen sind. Schein bar läuft es jetzt stabil.
Hast Du folgendes in der configuration.yaml eingetragen:

Code: Alles auswählen

logger:
  default: info
  logs:
    fritzconnection: info
Das ist seit der Home Assistant Core 2021.11.x notwendig, da ansonsten das Log durch irgendwelche Firtz!Box Meldungen überläuft. Damit könnte Dein Problem auch zu tun haben.
Dieses Problem ist anscheinend ab der 2021.12.x behoben, wenn ich das richtig verstanden habe.
Oh, das ging an mir vorbei ^^
Aber ich hab jetzt mal alles deaktiviert, zumal die Fritte bei mir eh nur Telefonie macht ...
Benutzeravatar
Osorkon
Administrator
Beiträge: 238
Registriert: Sa 17. Jul 2021, 16:53
Wohnort: Langenargen
Kontaktdaten:

Re: HA hängt sich immer wieder auf

Beitrag von Osorkon »

carsten_h hat geschrieben: Mo 29. Nov 2021, 08:57 Das Problem ist, daß die neueren Releases von Home Assistant OS sich irgendwie nicht mit UAS von einigen USB-SATA Bridges vertragen
Ich habe zwar keinerlei Stabilitätsprobleme mit HA auch klage ich nicht über Aufhänger.
Das Laden der Logdatei dauert bei mir auch länger als 20s. Das war aber nicht immer so?!
Weiss nicht ab das jetzt an HA OS Version liegt. Oder an der Hardware. Den seit ca. 2 Monate verwende ich auch das Argon One Gehäuse.

Aber das Deaktivieren von UASP hat tatsächlich zur Lösung beigetragen. Auch wenn die Lesegeschwindigkeit von 733MB auf 657MB in 3s gesunken ist?!

Danke @carsten_h an der Stelle für den Tipp.

Weitere Hintergründe zu USAP in Verbindung mit einem Raspberry Pi4 könnt ihr hier finden.
War für mich zumindest hilfreich zu verstehen, was sich dahinter verbirgt.

Gruß
Osorkon
Einer muss ja für Ordnung sorgen. :D
Benutzeravatar
carsten_h
Beiträge: 117
Registriert: Mo 2. Aug 2021, 11:07
Wohnort: Wunstorf

Re: HA hängt sich immer wieder auf

Beitrag von carsten_h »

Osorkon hat geschrieben: Mo 29. Nov 2021, 18:05Das war aber nicht immer so?!
Nein, das fing erst ab irgendeiner Home Assistant OS Version dieses Jahr an. Daher schreibe ich ja auch, daß es an Home Assistant OS und nicht an UAS liegt.
Osorkon hat geschrieben: Mo 29. Nov 2021, 18:05Den seit ca. 2 Monate verwende ich auch das Argon One Gehäuse.
Es könnte natürlich auch sein, daß der Controller vorher UAS gar nicht unterstützt hat.
Osorkon hat geschrieben: Mo 29. Nov 2021, 18:05Auch wenn die Lesegeschwindigkeit von 733MB auf 657MB in 3s gesunken ist?!
Ja, so hätte ich das auch erwartet, da UAS (USB attached SCSI) ja dafür sorgt, daß Zugriffe schneller erfolgen können. Bei mir war es aber interessanterweise hinterher eher etwas schneller.
Benutzeravatar
Osorkon
Administrator
Beiträge: 238
Registriert: Sa 17. Jul 2021, 16:53
Wohnort: Langenargen
Kontaktdaten:

Re: HA hängt sich immer wieder auf

Beitrag von Osorkon »

@carsten_h hast Du UAS auch mit HA OS 7.0 deaktiviert?
Bzw. kann ich mit dieser Modifikation problemlos auf OS 7.0 aktualisieren?

Vielen Dank & Gruß

Osorkon
Einer muss ja für Ordnung sorgen. :D
Benutzeravatar
carsten_h
Beiträge: 117
Registriert: Mo 2. Aug 2021, 11:07
Wohnort: Wunstorf

Re: HA hängt sich immer wieder auf

Beitrag von carsten_h »

Osorkon hat geschrieben: Do 23. Dez 2021, 22:40kann ich mit dieser Modifikation problemlos auf OS 7.0 aktualisieren?
Ich habe UASP irgendwann im November deaktiviert und nicht wieder aktiviert.
Ich benutze jetzt Home Assistant OS 7.0, Core 2021.12.5 und Supervisor 2021.12.
Benutzeravatar
Osorkon
Administrator
Beiträge: 238
Registriert: Sa 17. Jul 2021, 16:53
Wohnort: Langenargen
Kontaktdaten:

Re: HA hängt sich immer wieder auf

Beitrag von Osorkon »

carsten_h hat geschrieben: Do 23. Dez 2021, 22:51 Ich habe UASP irgendwann im November deaktiviert und nicht wieder aktiviert.
Vielen Dank für die schnelle Antwort.

Heisst also ich kann gefahrlos auf 7.0 updaten.

Danke und Gruß

Osorkon
Einer muss ja für Ordnung sorgen. :D
Benutzeravatar
carsten_h
Beiträge: 117
Registriert: Mo 2. Aug 2021, 11:07
Wohnort: Wunstorf

Re: HA hängt sich immer wieder auf

Beitrag von carsten_h »

Osorkon hat geschrieben: Do 23. Dez 2021, 22:55Heisst also ich kann gefahrlos auf 7.0 updaten.
Ja sicher.
Und selbst wenn es Probleme gibt, wird vor der Installation ein Backup erstellt. Du kannst also immer auf den Punkt davor zurückgehen.
Antworten